Problems unmounting with voyage.update

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems unmounting with voyage.update

Erik van Linstee
Hi,

I recently noticed that if I create a new CF using voyage.update, at the
end of the process the script complains that /mnt/cf/dev and /mnt/cf
can't be unmounted.
If I then unmount them manually, there is no problem.

I traced the problem to setboot.sh, where an attempt is made to unmount
/mnt/cf/dev, right after GRUB has been set up. If I add a sleep 1 before
the unmount, there is no problem.

Apparently there is a timing problem, which could in my case be due to
the CF being mounted in a USB card-reader. I have reproduced the same
behaviour on more than one machine, with different card readers (same
make though).

It seems that the failure to unmount does not result in an unfinished
CF. Apparently the installation script is done anyway. But it might be
smart to fix it, just to make sure people do not get confused by it.

regards,
Erik van Linstee

_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|

Re: Problems unmounting with voyage.update

Kim-man 'Punky' TSE-2
Hi Erik,
>
> I traced the problem to setboot.sh, where an attempt is made to unmount /mnt/cf/dev, right after GRUB has been set up.
> If I add a sleep 1 before the unmount, there is no problem.
If you get another chance to reproduce it, could you add "sync" instead of "sleep 1" before unmount?
>
> regards,
> Erik van Linstee

--
Regards,
Kim-man "Punky" Tse

* Open Source Embedded Solutions and Systems
   - Voyage Linux (http://linux.voyage.hk)
   - Voyage MPD   (http://linux.voyage.hk/voyage-mpd)
   - Voyage MuBox (http://mubox.voyage.hk)
* Voyage Store   (http://store.voyage.hk)


_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|

Re: Problems unmounting with voyage.update

Erik van Linstee


On 07-08-15 03:48, Kim-man 'Punky' TSE wrote:
> Hi Erik,
>>
>> I traced the problem to setboot.sh, where an attempt is made to
>> unmount /mnt/cf/dev, right after GRUB has been set up. If I add a
>> sleep 1 before the unmount, there is no problem.
> If you get another chance to reproduce it, could you add "sync"
> instead of "sleep 1" before unmount?

I will, but it might take some time before I get around to it.

Erik

_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux