Voyage 0.11.0 and APU2 no LEDs

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Voyage 0.11.0 and APU2 no LEDs

Richard Warburton
Fresh install of Voyage 0.11.0, alas on startup I see the message:
/etc/init.d/voyage-util: 76: /etc/init.d/voyage-util: cannot create /sys/class/leds/apu2:1/trigger: Directory nonexistent
/etc/init.d/voyage-util: 77: /etc/init.d/voyage-util: cannot create /sys/class/leds/apu2:3/trigger: Directory nonexistent
/etc/init.d/voyage-util: 78: /etc/init.d/voyage-util: cannot create /sys/class/leds/apu2:3/trigger: Directory nonexistent
/etc/init.d/voyage-util: 79: /etc/init.d/voyage-util: cannot create /sys/class/leds/apu2:3/trigger: Directory nonexistent

Looking inside /sys/class/leds, there's only one directory called mmc0::

Is there a simple fix for this?  I tried the current release as well, but no dice.

Thanks in advance.

_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|

Re: Voyage 0.11.0 and APU2 no LEDs

Richard Warburton
Thanks Andreas,

Voyage 0.11.0 explicitly says that it supports APU2 leds in the release data (unless I'm reading it wrong), so I'm hoping it's a minor config issue.

If I have no luck, I might have a go with the sources you provide.

Thanks again.

On 16 June 2017 at 17:18, <[hidden email]> wrote:
Hello Richard

I don't know about a simple fix. On my APU2s with Voyage 0.10.0, the kernel module has been missing.

Using the Voyage SDK, I've compiled and installed the missing kernel module using this sources:
http://daduke.org/dl/apu2-leds.tgz

On Voyage 0.11.0, it could be the same problem.

Cheers
Andreas



On 2017-06-16 07:06, Richard Warburton wrote:
Fresh install of Voyage 0.11.0, alas on startup I see the message:
/etc/init.d/voyage-util: 76: /etc/init.d/voyage-util: cannot create
/sys/class/leds/apu2:1/trigger: Directory nonexistent
/etc/init.d/voyage-util: 77: /etc/init.d/voyage-util: cannot create
/sys/class/leds/apu2:3/trigger: Directory nonexistent

/etc/init.d/voyage-util: 78: /etc/init.d/voyage-util: cannot create
/sys/class/leds/apu2:3/trigger: Directory nonexistent

/etc/init.d/voyage-util: 79: /etc/init.d/voyage-util: cannot create
/sys/class/leds/apu2:3/trigger: Directory nonexistent

Looking inside /sys/class/leds, there's only one directory called
mmc0::

Is there a simple fix for this?  I tried the current release as well,
but no dice.

Thanks in advance.
_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux



--
Richard Warburton - MSc(Hons), PGDipSci, BE(Hons) +64 9 377-2881 ext 9
Skagerrak Software - Senior Developer - http://www.skagerraksoftware.com/
40/22a Willcott St, Mt Albert 1025 - PO Box 77039, Mt Albert, Auckland 1350

_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|

Re: Voyage 0.11.0 and APU2 no LEDs

Richard Warburton
Hi Bolle,

Yes, your email got the leds fully working! Many thanks.

For anyone else following, the modules exist but aren't being loaded on startup.
After editing /etc/modules as you suggested, I was able turn the leds on an off but no heartbeat or timer etc.
Adding VOYAGE_SYSTEM_MODULES to vi /etc/voyage.conf did nothing, but I could load them all by hand.
So I simply added the module list to: vi /etc/modules (as opposed to just leds-apu2).

And that was that.

Thanks again Bolle!



On 16 June 2017 at 18:01, <[hidden email]> wrote:
Again me ;-)

Maybe this could help you or bring you into the right direction.

This is an excerpt from my manual installation:

APU2# cp leds-apu2.ko /lib/modules/3.16.7-ckt9-voyage/kernel/drivers/leds/
APU2# depmod -a
APU2# vi /etc/modules

leds-apu2
<<<
APU2# modprobe leds-apu2

APU2# vi /etc/voyage.conf

VOYAGE_PROFILE=APU2
VOYAGE_SYSTEM_MODULES="sp5100-tco; led-class; ledtrig-heartbeat; ledtrig-timer; ledtrig-netdev; leds-apu2;"
<<<

APU2# vi /etc/init.d/voyage-util

                'APU2')
                        echo heartbeat > /sys/class/leds/apu2\:2/trigger
                        echo ata1 > /sys/class/leds/apu2\:3/trigger
                        ;;
<<<

The paths would differ on Voyage 0.11.0. The ">>>" and "<<<" are only markers.

I would check the following:

 - Does the kernel module exist ?
 - Can you load the kernel module by hand ?
 - Is the kernel module in the Voyage profile ?

Andreas


On 2017-06-16 07:26, Richard Warburton wrote:
Thanks Andreas,

Voyage 0.11.0 explicitly says that it supports APU2 leds in the
release data (unless I'm reading it wrong), so I'm hoping it's a minor
config issue.

If I have no luck, I might have a go with the sources you provide.

Thanks again.

On 16 June 2017 at 17:18, <[hidden email]> wrote:

Hello Richard

I don't know about a simple fix. On my APU2s with Voyage 0.10.0, the
kernel module has been missing.

Using the Voyage SDK, I've compiled and installed the missing kernel
module using this sources:
http://daduke.org/dl/apu2-leds.tgz [2]


On Voyage 0.11.0, it could be the same problem.

Cheers
Andreas

On 2017-06-16 07:06, Richard Warburton wrote:

Fresh install of Voyage 0.11.0, alas on startup I see the
message:
/etc/init.d/voyage-util: 76: /etc/init.d/voyage-util: cannot
create
/sys/class/leds/apu2:1/trigger: Directory nonexistent
/etc/init.d/voyage-util: 77: /etc/init.d/voyage-util: cannot
create
/sys/class/leds/apu2:3/trigger: Directory nonexistent

/etc/init.d/voyage-util: 78: /etc/init.d/voyage-util: cannot
create
/sys/class/leds/apu2:3/trigger: Directory nonexistent

/etc/init.d/voyage-util: 79: /etc/init.d/voyage-util: cannot
create
/sys/class/leds/apu2:3/trigger: Directory nonexistent

Looking inside /sys/class/leds, there's only one directory called
mmc0::

Is there a simple fix for this?  I tried the current release as
well,
but no dice.

Thanks in advance.
_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux [1]

--

Richard Warburton - MSc(Hons), PGDipSci, BE(Hons) <a href="tel:%2B64%209%20377-2881%20ext%209" value="+6493772881" target="_blank">+64 9 377-2881 ext 9
Skagerrak Software - Senior Developer -
http://www.skagerraksoftware.com/

40/22a Willcott St, Mt Albert 1025 - PO Box 77039, Mt Albert, Auckland
1350

Links:
------
[1] http://list.voyage.hk/mailman/listinfo/voyage-linux
[2] http://daduke.org/dl/apu2-leds.tgz



--
Richard Warburton - MSc(Hons), PGDipSci, BE(Hons) +64 9 377-2881 ext 9
Skagerrak Software - Senior Developer - http://www.skagerraksoftware.com/
40/22a Willcott St, Mt Albert 1025 - PO Box 77039, Mt Albert, Auckland 1350

_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|

Re: Voyage 0.11.0 and APU2 no LEDs

Kim-man 'Punky' TSE-2
In reply to this post by Richard Warburton
Hi Richard,

Please check if leds_apu2 is loaded?  Use command:

lsmod|grep leds

Regards,
Punky


On 6/16/2017 1:06 PM, Richard Warburton wrote:

> Fresh install of Voyage 0.11.0, alas on startup I see the message:
> /etc/init.d/voyage-util: 76: /etc/init.d/voyage-util: cannot create /sys/class/leds/apu2:1/trigger: Directory nonexistent
> /etc/init.d/voyage-util: 77: /etc/init.d/voyage-util: cannot create /sys/class/leds/apu2:3/trigger: Directory nonexistent
> /etc/init.d/voyage-util: 78: /etc/init.d/voyage-util: cannot create /sys/class/leds/apu2:3/trigger: Directory nonexistent
> /etc/init.d/voyage-util: 79: /etc/init.d/voyage-util: cannot create /sys/class/leds/apu2:3/trigger: Directory nonexistent
>
> Looking inside /sys/class/leds, there's only one directory called mmc0::
>
> Is there a simple fix for this?  I tried the current release as well, but no dice.
>
> Thanks in advance.
>
>
> _______________________________________________
> Voyage-linux mailing list
> [hidden email]
> http://list.voyage.hk/mailman/listinfo/voyage-linux


--
Regards,
Kim-man "Punky" Tse

* Open Source Embedded Solutions and Systems
   - Voyage Linux (http://linux.voyage.hk)
   - Voyage MPD   (http://linux.voyage.hk/voyage-mpd)
   - Voyage MuBox (http://mubox.voyage.hk)
* Voyage Store   (http://store.voyage.hk)


_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux