voyage mpd 0.10.0 problem on NUC

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

voyage mpd 0.10.0 problem on NUC

chezmichaelng
Hi Punky,

Just bought a GIGABYTE BRIX NUC and install voyage mpd 0.10.0 into the internal SSD, all went well to setup mpd with NAS server. MPaD can see my library, but can't play them. WebGUI showed an error in output device. I tried changing mpd.config>device "hw:X,Y", some setting can play but still no sound. Please help.

Best Regards,
Michael
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: voyage mpd 0.10.0 problem on NUC

Kim-man 'Punky' TSE-2
On 7/18/2015 8:34 PM, chezmichaelng wrote:
> MPaD can see my
> library, but can't play them. WebGUI showed an error in output device. I
> tried changing mpd.config>device "hw:X,Y", some setting can play but still
> no sound. Please help.
Perhaps a known problem.  Please check using

cat /proc/asound/cards

to see if your DAC cards is listed?

--
Regards,
Kim-man "Punky" Tse

* Open Source Embedded Solutions and Systems
   - Voyage Linux (http://linux.voyage.hk)
   - Voyage MPD   (http://linux.voyage.hk/voyage-mpd)
   - Voyage MuBox (http://mubox.voyage.hk)
* Voyage Store   (http://store.voyage.hk)


_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: voyage mpd 0.10.0 problem on NUC

chezmichaelng
Hi Punky,

looks like voyage mpd cannot detect USB of the NUC

root@voyage:~# cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xf7214000 irq 61
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7210000 irq 59
root@voyage:~#

Best Regards
Michael
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: voyage mpd 0.10.0 problem on NUC

Muffinman
On 21/07/15 15:32, chezmichaelng wrote:
> Hi Punky,
>
> looks like voyage mpd cannot detect USB of the NUC
>
Hello chezmichaelng,

Was the dac powered on while you booted Voyage? I found that
/etc/modprobe.d/alsa-base.conf is a bit limited out of the box. This
causes dac's to be recognized only on boot.

I took the contents of this file from a previous Voyage MPD version, now
it works fine for me, see the below.

Kind regards, Maarten


---------- /etc/modprobe.d/alsa-base.conf --------
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe
--quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && {
/sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && {
/sbin/modprobe --quiet snd-emu10k1-synth ; : ; }
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd_dummy index=-2
----------- END.


_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: voyage mpd 0.10.0 problem on NUC

Muffinman
On 21/07/15 15:59, Muffinman wrote:
> I took the contents of this file from a previous Voyage MPD version, now
> it works fine for me, see the below.

One note: the following should be three lines (beginning with 'install')
instead of the wrapped
versions...

install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe
--quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && {
/sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && {
/sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

Kind regards, Maarten

_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: voyage mpd 0.10.0 problem on NUC

Kim-man 'Punky' TSE-2
In reply to this post by chezmichaelng
Hi Michael,

This is an know issue, in /etc/modprobe.d/alsa-base.conf, please change:

options snd-usb-audio index=0
to
options snd-usb-audio index=-1
or
options snd-usb-audio index=-2


On 7/21/2015 9:32 PM, chezmichaelng wrote:

> Hi Punky,
>
> looks like voyage mpd cannot detect USB of the NUC
>
> root@voyage:~# cat /proc/asound/cards
>   0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
>                        HDA Intel HDMI at 0xf7214000 irq 61
>   1 [PCH            ]: HDA-Intel - HDA Intel PCH
>                        HDA Intel PCH at 0xf7210000 irq 59
> root@voyage:~#
>
> Best Regards
> Michael
>
>
>
> --
> View this message in context: http://voyage-linux.34677.n3.nabble.com/voyage-mpd-0-10-0-problem-on-NUC-tp4026345p4026350.html
> Sent from the Voyage Linux mailing list archive at Nabble.com.
>
> _______________________________________________
> Voyage-linux mailing list
> [hidden email]
> http://list.voyage.hk/mailman/listinfo/voyage-linux


--
Regards,
Kim-man "Punky" Tse

* Open Source Embedded Solutions and Systems
   - Voyage Linux (http://linux.voyage.hk)
   - Voyage MPD   (http://linux.voyage.hk/voyage-mpd)
   - Voyage MuBox (http://mubox.voyage.hk)
* Voyage Store   (http://store.voyage.hk)


_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: voyage mpd 0.10.0 problem on NUC

chezmichaelng
Thanks Punky, it worked.

Best Regards,
Michael

> On Jul 22, 2015, at 9:57 AM, Kim-man 'Punky' TSE <[hidden email]> wrote:
>
> Hi Michael,
>
> This is an know issue, in /etc/modprobe.d/alsa-base.conf, please change:
>
> options snd-usb-audio index=0
> to
> options snd-usb-audio index=-1
> or
> options snd-usb-audio index=-2
>
>
> On 7/21/2015 9:32 PM, chezmichaelng wrote:
>> Hi Punky,
>>
>> looks like voyage mpd cannot detect USB of the NUC
>>
>> root@voyage:~# cat /proc/asound/cards
>>  0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
>>                       HDA Intel HDMI at 0xf7214000 irq 61
>>  1 [PCH            ]: HDA-Intel - HDA Intel PCH
>>                       HDA Intel PCH at 0xf7210000 irq 59
>> root@voyage:~#
>>
>> Best Regards
>> Michael
>>
>>
>>
>> --
>> View this message in context: http://voyage-linux.34677.n3.nabble.com/voyage-mpd-0-10-0-problem-on-NUC-tp4026345p4026350.html
>> Sent from the Voyage Linux mailing list archive at Nabble.com.
>>
>> _______________________________________________
>> Voyage-linux mailing list
>> [hidden email]
>> http://list.voyage.hk/mailman/listinfo/voyage-linux
>
>
> --
> Regards,
> Kim-man "Punky" Tse
>
> * Open Source Embedded Solutions and Systems
>  - Voyage Linux (http://linux.voyage.hk)
>  - Voyage MPD   (http://linux.voyage.hk/voyage-mpd)
>  - Voyage MuBox (http://mubox.voyage.hk)
> * Voyage Store   (http://store.voyage.hk)
>


_______________________________________________
Voyage-linux mailing list
[hidden email]
http://list.voyage.hk/mailman/listinfo/voyage-linux
Loading...